Be sure to update your browsers to block bad SSL certs from China


I just updated to the new Firefox 37 and you should too. Both Google and Firefox are now block SSL Certificates from China’s CNNIC Certificate Authority. They have be caught forging invalid certificates and you could be hacked if you visits websites that use these certificates.

Leave a Reply

Your email address will not be published. Required fields are marked *